YITH WooCommerce Compare: known security problems
7 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 7 known security problems on this page. Each one has a fixed version. Updating to version 3.15.1 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.15.0
- Fixed in
- 3.15.1
- What to do
- If your site has an affected version, update YITH WooCommerce Compare to version 3.15.1 or newer.
- Official ID
- CVE-2026-106604
- Report title
- YITH WooCommerce Compare <= 3.15.0 - Authenticated (Contributor+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could in some setups, take over your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.6.0
- Fixed in
- 3.7.0
- What to do
- If your site has an affected version, update YITH WooCommerce Compare to version 3.7.0 or newer.
- Official ID
- CVE-2026-22333
- Report title
- YITH WooCommerce Compare <= 3.6.0 - Authenticated (Admin+) PHP Object Injection
- First reported
- Sources
- Wordfence, seen
Someone could trick a logged-in admin into changing settings without knowing (up to and including 2.37.0)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.37.0
- Fixed in
- 2.38.0
- What to do
- If your site has an affected version, update YITH WooCommerce Compare to version 2.38.0 or newer.
- Official ID
- CVE-2024-32699
- Report title
- YITH WooCommerce Compare <= 2.37.0 - Cross-Site Request Forgery
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.20.0
- Fixed in
- 2.20.1
- What to do
- If your site has an affected version, update YITH WooCommerce Compare to version 2.20.1 or newer.
- Report title
- YITH plugins by YITHEMES <= (Various Versions) - Missing Authorization
- First reported
- Sources
- Wordfence, seen
Someone could trick a logged-in admin into changing settings without knowing (up to and including 2.20.0)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.20.0
- Fixed in
- 2.20.1
- What to do
- If your site has an affected version, update YITH WooCommerce Compare to version 2.20.1 or newer.
- Official ID
- CVE-2022-44630
- Report title
- YITH plugins by YITHEMES <= (Various Versions) - Cross-Site Request Forgery
- First reported
- Sources
- Wordfence, seen
Someone could use it to harm your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.3.13
- Fixed in
- 2.3.15
- What to do
- If your site has an affected version, update YITH WooCommerce Compare to version 2.3.15 or newer.
- Official ID
- CVE-2019-16251
- Report title
- YIT Plugin Framework <= 3.3.8 - Authenticated Settings Change
- First reported
- Sources
- Wordfence, seen
A stranger could in some setups, take over your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.0.9
- Fixed in
- 2.1.0
- What to do
- If your site has an affected version, update YITH WooCommerce Compare to version 2.1.0 or newer.
- Report title
- YITH WooCommerce Compare <= 2.0.9 - Unauthenticated PHP Object Injection
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)