YITH WooCommerce Wishlist: known security problems
12 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 12 known security problems on this page. Each one has a fixed version. Updating to version 4.19.0 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 4.18.1)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.18.1
- Fixed in
- 4.19.0
- What to do
- If your site has an affected version, update YITH WooCommerce Wishlist to version 4.19.0 or newer.
- Official ID
- CVE-2026-112199
- Report title
- YITH WooCommerce Wishlist <= 4.18.1 - Authenticated (Contributor+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to (before 4.18.1)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 4.18.1
- Fixed in
- 4.18.1
- What to do
- If your site has an affected version, update YITH WooCommerce Wishlist to version 4.18.1 or newer.
- Official ID
- CVE-2026-82305
- Report title
- YITH WooCommerce Wishlist < 4.18.1 - Missing Authorization
- First reported
- Sources
- Wordfence, seen
A stranger could use it to harm your site (up to and including 4.12.0)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.12.0
- Fixed in
- 4.13.0
- What to do
- If your site has an affected version, update YITH WooCommerce Wishlist to version 4.13.0 or newer.
- Official ID
- CVE-2026-27329
- Report title
- YITH WooCommerce Wishlist <= 4.12.0 - Unauthenticated Insecure Direct Object Reference
- First reported
- Sources
- Wordfence, seen
A stranger could use it to harm your site (before 4.13.0)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 4.13.0
- Fixed in
- 4.13.0
- What to do
- If your site has an affected version, update YITH WooCommerce Wishlist to version 4.13.0 or newer.
- Official ID
- CVE-2026-4432
- Report title
- YITH WooCommerce Wishlist < 4.13.0 - Unauthenticated Insecure Direct Object Reference to Wishlist Rename
- First reported
- Sources
- Wordfence, seen
A stranger could use it to harm your site (up to and including 4.10.0)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.10.0
- Fixed in
- 4.10.1
- What to do
- If your site has an affected version, update YITH WooCommerce Wishlist to version 4.10.1 or newer.
- Official ID
- CVE-2025-12777
- Report title
- YITH WooCommerce Wishlist <= 4.10.0 - Unauthenticated Wishlist Token Disclosure to Wishlist Item Deletion
- First reported
- Sources
- Wordfence, seen
A stranger could use it to harm your site (up to and including 4.10.0) (2)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.10.0
- Fixed in
- 4.10.1
- What to do
- If your site has an affected version, update YITH WooCommerce Wishlist to version 4.10.1 or newer.
- Official ID
- CVE-2025-12427
- Report title
- YITH WooCommerce Wishlist <= 4.10.0 - Unauthenticated Insecure Direct Object Reference to Unauthenticated Wishlist Rename
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 4.5.0)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.5.0
- Fixed in
- 4.6.0
- What to do
- If your site has an affected version, update YITH WooCommerce Wishlist to version 4.6.0 or newer.
- Official ID
- CVE-2025-5238
- Report title
- YITH WooCommerce Wishlist <= 4.5.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via id Parameter
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.32.0
- Fixed in
- 3.33.0
- What to do
- If your site has an affected version, update YITH WooCommerce Wishlist to version 3.33.0 or newer.
- Official ID
- CVE-2024-34385
- Report title
- YITH WooCommerce Wishlist <= 3.32.0 - Authenticated (Admin+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to (up to and including 3.14.0)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.14.0
- Fixed in
- 3.15.0
- What to do
- If your site has an affected version, update YITH WooCommerce Wishlist to version 3.15.0 or newer.
- Report title
- YITH plugins by YITHEMES <= (Various Versions) - Missing Authorization
- First reported
- Sources
- Wordfence, seen
Someone could trick a logged-in admin into changing settings without knowing
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.14.0
- Fixed in
- 3.15.0
- What to do
- If your site has an affected version, update YITH WooCommerce Wishlist to version 3.15.0 or newer.
- Official ID
- CVE-2022-44630
- Report title
- YITH plugins by YITHEMES <= (Various Versions) - Cross-Site Request Forgery
- First reported
- Sources
- Wordfence, seen
Someone could use it to harm your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.2.13
- Fixed in
- 2.2.14
- What to do
- If your site has an affected version, update YITH WooCommerce Wishlist to version 2.2.14 or newer.
- Official ID
- CVE-2019-16251
- Report title
- YIT Plugin Framework <= 3.3.8 - Authenticated Settings Change
- First reported
- Sources
- Wordfence, seen
Someone could read or change the data in your site’s database
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.1.2
- Fixed in
- 2.2.0
- What to do
- If your site has an affected version, update YITH WooCommerce Wishlist to version 2.2.0 or newer.
- Report title
- YITH WooCommerce Wishlist <= 2.1.2 - SQL Injection
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)